CISCO ROUTING INFORMATION PROTOCOL (RIP)

The Routing Information Protocol (RIP) is one of the oldest distance-vector routing protocols which employs the hop count as a routing metric. RIP prevents routing loops by implementing a limit on the number of hops allowed in a path from source to destination. Now we will apply and practice Cisco RIP by example.

Exercise 1

See the picture above, first please define the IP Address on Router 1, Router 2, and Router 3. Follow the command below,

  • hostname R1

    int e0/0

    ip addr 13.1.1.1 255.255.255.0

    no shutdown

    int e0/1

    ip addr 12.1.1.1 255.255.255.0

    no shutdown

    int lo 0

    ip addr 13.1.1.1 255.255.255.0

    ip addr 1.1.1.1 255.255.255.0

    no shutdown

    do write

    do show ip int brief

    • hostname R2

      int e0/0

      ip addr 23.1.1.2 255.255.255.0

      no shutdown

      int e0/1

      ip addr 12.1.1.2 255.255.255.0

      no shutdown

      int lo 0

      ip addr 2.2.2.2 255.255.255.0

      no shutdown

      do write

      do show ip int brief

      • hostname R3

        int e0/0

        ip addr 13.1.1.3 255.255.255.0

        no shutdown

        int e0/1

        ip addr 23.1.1.3 255.255.255.0

        no shutdown

        int lo 0

        ip addr 3.3.3.3 255.255.255.0

        no shutdown

        do write

        do show ip int brief

      • To make sure the IP Address is correctly, you can check by command do show ip int brief, see the picture below

        Now, you can try to ping from each Router before setting the Router Rip step, See the figure below,

        And also you can try to ping the loopback, try the command below

      • ping 1.1.1.1 source 2.2.2.2

        ping 1.1.1.1 repeat 10 source 23.1.1.2

        ping 1.1.1.1 repeat 10 source 2.2.2.2

      You can see the result by the following picture,

      Now you can add the Router RIP to every Router, run the command below,

      • hostname R1

        router rip

        version 2

        no auto-summary

        network 13.1.1.0

        network 12.1.1.0

        network 1.1.1.0

        exit

        do show run

        show ip route rip

        • hostname R2

          router rip

          version 2

          no auto-summary

          network 12.1.1.0

          network 23.1.1.0

          network 2.2.2.0

          exit

          do show run

          show ip route rip

          • hostname R3

            router rip

            version 2

            no auto-summary

            network 13.1.1.0

            network 23.1.1.0

            network 3.3.3.0

            exit

            do show run

            show ip route rip

          • See the picture below, you can use the open-source packet analyzer, to see more clearly how Router RIP works,

            While, Loopback is virtual interfaces in cisco router, now you can add more loopback, we will try at Router 3, run command below,

            • int lo 1

              ip addr 172.16.0.1 255.255.255.0

              no shutdown

              int lo 2

              ip addr 172.16.1.1 255.255.255.0

              no shutdown

              int lo 3

              ip addr 172.16.2.1 255.255.255.0

              no shutdown

              int lo 4

              ip addr 172.16.3.1 255.255.255.0

              no shutdown

              do sh ip int brief

              router rip

              network 172.16.0.0

              do show run

              ctrl +Z

              show ip route

            You can see the result by the following picture,

            Router RIP - Passive Interface

            Passive Interface will ensure that the network is advertised in RIP but it will not send RIP updates on the interface. You can see the picture above, In this case to apply the passive interface is when the R3 just want to execute 172.0.23.0/24, but not 172.0.34.0/24. So now, please define the ip address on Router 1, Router 2 and Router 3, and do the same things for router rip command, and after that you can apply the passive interface, there are two methods that you can apply,

            First method is using network 172.0.0.0 will make both interface become RIP, so one must be added command to prevent e0/1 from performing RIP,

            • passive-interface

            Second method is make all interface passive, and then no interface will be executed, run command,
            • passive-interface default

              on passive-interface e0/0

            Router RIP - Default Information Originate

            To generate a default route into the Routing Information Protocol (RIP), use the default-information originate command. Now, R2 wants to release default route to R1 and R3, so we just use following command,

            • router rip

              default-information originate